Confirmed compatibility with the latest Proxmox VE 9.1 version
Added "Completed Backup Tasks per Storage" graph, complementing the current per-node view
Improvement
Enhanced queue management for synchronization and backup operations, with prioritized queues, interval controls, and safeguards to prevent overlapping backup tasks. Note: For more details, see the updated Queue and Backups Logic documentation
Added validation preventing downgrades of configurable options below the current resource usage
Improved validation of the "Comment" field in the "Create Firewall Rule" form to allow spaces, dots, and commas, aligning with Proxmox standards - case #694
Implemented validation to restrict the machine name and description fields to a maximum of 64 characters to prevent display and configuration errors - case #714
Updated bandwidth quota calculation to use base-10 (1000) instead of base-2 (1024) when converting units, matching WHMCS standards - case #723
Bug Fix
Fixed issue where creating a machine using an ISO resulted in an error during the task creation process - case #705
Corrected issue in the VPS job agent where executing the "Change Hostname" action caused the "Call to a member function hostnameUpdate() on null" error - case #706
Corrected execution of the "Backup Jobs Update" task to skip inactive services and avoid lookup errors - case #707
Fixed issue where the password field was not cleared after a password change in the client area - case # 711
Corrected applications list update to ensure custom configurations are preserved when using the "Update existing items only" option - case # 713
Resolved issue where editing a single additional disk during a virtual machine creation caused the remaining disks to disappear - case #715
Corrected behaviour of the Load Balancer to ignore offline hosts when selecting target allocation for a new virtual machine - case #722
Corrected IP assignment when creating virtual machines with predefined network tags, ensuring proper detection and allocation of available addresses - case #724
Restored missing 'snapshots' command in the cron scheduler to appear and operate correctly - case #725
Fixed problem with correct display of username, password and realm variables in Client Notifications emails - case #737
Corrected validation rules keeping Search Domain, Name Server and Second Name Server fields optional in edit view - case #740
Integration with the Server Monitoring For WHMCS module which introduces a dedicated section in the client area to control server health - case #2051
Configure the "TPM" feature for KVM servers using a dedicated configurable option - case #2007
Separate option to "Automatically Create Private Network" even when the previously used "Private Network" option is disabled - case #1882
Added "keepPasswordFieldsEmpty " configuration flag to the "global_options.yml" file, which, when set to "true", automatically clears passwords from WHMCS fields after server creation to comply with legal requirements - case #2045
Changed
The "Private Network" option has been renamed to "Network Creation Button" and now controls whether clients can create their private networks in the client area instead of automatically creating an interface during server setup - case #1882
Updated file restoration "Queue Files Larger Than" option in the addon module, now it can be set to "0" to queue all files or "-1" to disable the feature - case #311
Changed the way email notifications are sent for failed scheduled backups - instead of sending a notification for each scheduled backup job error, it will be sent only after the 10th failed task to avoid spamming the mailbox with redundant notifications - case #316
Removed
Support for WHMCS V8.8 and previous
Support for PHP 7.4 version
Bug Fix
Eliminated "TypeError: Unsupported operand types (...)" that might have occurred when upgrading services using configurable options without creating "Protected Backup Files Limit" - case #1999
Solved problem where all OS templates might have been visible for server reinstallation despite limitations set using "OS Groups" in the module settings - case #2002
Fixed "500" error that could occur when restoring backups or viewing networks if no disk drive was in the boot order or not set as the first device - case #2013
Unnecessary guest agent task, for changing hostname on "Linux" OS when Cloud-Init is in use, will no longer be performed - case #2016
Corrected problem with encrypted cloud-init password after server reinstallation from a template - case #2054
Fixed issue where the VM might not start after a rebuild due to the existence of an SDN network interface - case #2049
Resolved problem with the "Empty replay from server" error that could occur when trying to download a backup due to differences between the used IP address and node address in the request - case #2048
Corrected limitation setting of "Protected Backup Files" which may have been taken incorrectly when set to 0, -1, or left blank - case #2043
Removed "Restore Backup File" client area feature for LXC configurations, as it is not supported for this virtualization type
Eliminated issue regarding the "preg_match(): Argument #2 (closed) ($subject) must be of type string, array given" error that could be shown when trying to migrate LXC machine to another node - case #2061
Fixed problem where the "Ram Assigned" counter on the "Servers List" displayed zero values - case #312
Resolved issue where "Node Details" could not be loaded in the addon module - case #310
Prevented duplication of backup synchronization tasks - case #315
Added option to control "Download Backup Files" and "Restore Backup Files" settings through "Client Area Features" and "Configurable Options" - case #1972
Added "Backup File Restoration" options in the addon module general settings allowing to define the maximum size of downloadable backup files, queue files larger than a specific size, select a notification email template to be sent once queued backup files are ready, and to set a custom storage path for backup files - case #1979, #1982
Option to customize the "Password Length" with the minimum number of characters required, overriding the default value of 12 characters - case #1987
Changed
Replaced KVM "Disk Usage" server information with the "Root Disk" with fixed size details, due to API response limitations - case #1981
Bug Fix
Resolved multiple issues related to downloading large backup files - case #1971, #1974
The "Update Snippet" task will now be properly added to the queue when editing the server's hostname or SSH public key - case #1966
Corrected Windows OS password validation when generating a new one - case #1968
Adjusted the "Reboot" VM action for VM power tasks - case #1984
Fixed problem where the "Maximum Network Rate" task could be added infinitely when the "Network Rate" configurable option was created and used in "Alternative Mode" - case #1985
Solved case where the "Reboot VM" task could get stuck in a loop with the "Task ID is empty" error - case #1991
Corrected integration with the IP Manager For WHMCS module Note: The recently released IP Manager module in version v3.1.0 is required to apply the fix